Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • Please do not post a message for the purpose of insulting, incitement to hatred, sexual remarks and any other which does not respect our terms of use !
Sign in to follow this  
HeyMan

 archive Besoin d'aide :eha

Recommended Posts

Désolé encore de déranger, mais après avoir remplacer tout pour l'eventalert ça bug toujours et dés que je fais la commande y'a marqué :follow machin... j'ai redemmaré l'ému, suivi toute les étapes, rien ne fait... Toujours :follow truc une alerte normal, je ne comprend pas qu'est-ce que je dois faire en plus? Merci! 

Share this post


Link to post
Share on other sites
Admin
Admin

Explique mieux ton problème j'ai rien compris :etonne:

Share this post


Link to post
Share on other sites

Donc,

Ma commande :eventalert ne marchait pas, et du coup j'ai rajouté dans la db command_event_alert (un truc dans le genre), puis je suis allé dans HabboHotel => Rooms => Chat => Commands => Event => EventAlertCommand.cs et j'ai tout supprimé et remplacer par ça

 

using Plus.Communication.Packets.Outgoing.Moderation;
using Plus.Communication.Packets.Outgoing.Rooms.Notifications;
using Plus.HabboHotel.GameClients;
using System;
namespace Plus.HabboHotel.Rooms.Chat.Commands.Events
{
    internal class EventAlertCommand : IChatCommand
    {
        public string PermissionRequired
        {
            get
            {
                return "command_event_alert";
            }
        }
        public string Parameters
        {
            get
            {
                return "";
            }
        }
        public string Description
        {
            get
            {
                return "Envoyer une alerte à  tout l'hà´tel pour prévenir les joueurs le début d'une animation!";
            }
        }
        public void Execute(GameClients.GameClient Session, Rooms.Room Room, string[] Params)
        {
            if (Params.Length == 1)
            {
                Session.SendWhisper(":eventalert + description.");
                return;
            }

            string Message = CommandManager.MergeParams(Params, 1);
            PlusEnvironment.GetGame().GetClientManager().SendMessage(new RoomNotificationComposer("Message des animateurs", "Une nouvelle animation se déroule chez <b>" + Room.OwnerName + "</b>.\n\nDépêche toi de participer avant que l'appart ne soit fermé ! Clique sur le bouton <b><i> Aller dans l'appart</i></b> pour participer à  l'animation. \n\n" + "<b>Plus de détails: </b>" + Message + "\n\n", "eventoshust", "Aller dans l'appart", "event:navigator/goto/" + Session.GetHabbo().CurrentRoom.RoomId));
            return;
        }
    }
}

ensuite j'ai ouvert le fichier Plus Emulator.sln et redémarrer l'émulateur et aucun effet

Share this post


Link to post
Share on other sites

tu as simplement oublier de debug la source .. Il suffit pas de redémaré l'emulateur, il faut cliquer sur le bouton " play " en vert normalement sur visual, il vas lancer ton emulateur sur la logiciel, une fois ceci fais tu peux éteindre et test 

Share this post


Link to post
Share on other sites
Premium

un peu de réflexion sa aide cherche une icone de ce type:        3374dd07e4.png

introduction_to_windows_forms_using_visu

Share this post


Link to post
Share on other sites
Donateur

Sinon, à la place de play ça peut être écris "démarrer".

Share this post


Link to post
Share on other sites

VRkaz23.png

Je dois sélectionner quoI?

ça m'énerve sérieux ça fait 2 ans que j'essaye de fixer cette putain de commande de mes couilles! flèche verte marche meme pas ça fait sélectionner un élément mais quoi comment sérieux merde

merci de votre aide mais ça m'énerve c'est tout 

Share this post


Link to post
Share on other sites
Admin
Admin
il y a 22 minutes, HeyMan a dit :

Please login or register to see this link.

Je dois sélectionner quoI?

ça m'énerve sérieux ça fait 2 ans que j'essaye de fixer cette putain de commande de mes couilles! flèche verte marche meme pas ça fait sélectionner un élément mais quoi comment sérieux merde

merci de votre aide mais ça m'énerve c'est tout 

1- ouvre Visual Studio 

2- une fois ouvert, va sur fichier en haut puis ouvrir > projet/Solution... 

3- Une fenêtre s'ouvrira, tu va dans le dossier de ton ému, puis tu ouvre PlusEmulator.sln

4- tu attends et une fois chargé, sur la droite de Visual Studio, tu auras les dossiers de ton émulateur, donc va dans le dossier de tes commandes. 

5- une fois dans le dossier de tes commandes, va dans user > fun puis copie colle une commande (fichier .cs) 

6- une fois effectué ouvre la commande copié, supprime ce qu'il y a dedans, et colle le code que tu as eu (tu peux aussi renommer le fichier si ta envie). 

7- enregistre, va dans commandmanager.cs en dessous de commandmimic par exemple tu colle la ligne qui t'ai été donnée avec  la commande puis enregistre et fait le flèche verte ou il y  a écrit start ou démarrer. 

8- dans ta db table permission_command tu ajoute ce qu'il ta donné, tu enregistre. 

 

Redémarre ton ému normalement ca sera ok

Share this post


Link to post
Share on other sites

Merci énormément pour ça jason, mais dés que j'appuie flèche verte il me dit choisi un élément de démarrage valide je fais quoi??

 

EDIT: ça marchait pas car il y avait pas net. framework je réessaye

Share this post


Link to post
Share on other sites
Admin
Admin

Ton émulateur est éteint lors de la manipulation ? 

Share this post


Link to post
Share on other sites
Admin
Admin

Essaie aussi de prendre une version plus récente de Visual Studio 

Share this post


Link to post
Share on other sites

Re, merci de ton aide, j'ai fermé l'ému mais j'ai toujours "Choisir un élément de démarrage" j'ai la dernière version de Visual studio (microsoft) je télécharge un truc peut être ça va marcher 

Share this post


Link to post
Share on other sites
Il y a 2 heures, HeyMan a dit :

Re, merci de ton aide, j'ai fermé l'ému mais j'ai toujours "Choisir un élément de démarrage" j'ai la dernière version de Visual studio (microsoft) je télécharge un truc peut être ça va marcher 

Viens en pv ou skype: Harda Web

Share this post


Link to post
Share on other sites
Admin
Admin

Salut,

Ton sujet est-il résolu? si c'est le cas merci d'éditer ton sujet en cliquant sur " Editer" Puis met le préfixe Résolu.

Note : Ton sujet sera archivé automatiquement si il n'est pas résolu sous 30 jours.

Thomas.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...