Jump to content
  • Please do not post a message for the purpose of insulting, incitement to hatred, sexual remarks and any other which does not respect our terms of use !
Sign in to follow this  
Chesterfield

 résolu "<?=$system->getDomain()?>" & HTTP ERROR 500

Recommended Posts

Premium

Holà H-Dev.

 

La function 

<?=$system->getDomain()?>

Est toujours d'actualité ou obsolète en version 7.2.7 de PHP ?

Ou c'est mieux de tout remplacer par son NDD ? 

erreur.PNG.cce26e2a69258cfaae9db3fb8c10af58.PNG

 

Je dis ça car j'ai une erreur de ce genre que je n'arrive point à résoudre.

 

oke.png.2f3ddbb6a9621e53822f588301bf0db8.png

 

Je m'en remet à vous. :humour-20-13--3fd04d:

Edited by 乇ᄊノしノѺ

Share this post


Link to post
Share on other sites
Premium
il y a 6 minutes, Scorpio a dit :

Il me semble qu'elle est obsolète dans php 7.2.7 mais je n'en suis pas sur, à ta place je mettrais direct le ndd pour être tranquille ^^

 Ok je vais faire ça et je te dis quoi ^^ Si ça fonctionne je met en résolu ;) 

Share this post


Link to post
Share on other sites
FireWork

Essaye:

$_SERVER['SERVER_NAME']

ou:

$_SERVER['REQUEST_URI']

Voir aussi:

Please login or register to see this link.

Please login or register to see this link.

Please login or register to see this link.

Please login or register to see this link.

Share this post


Link to post
Share on other sites
Premium
Il y a 2 heures, Scorpio a dit :

Il me semble qu'elle est obsolète dans php 7.2.7 mais je n'en suis pas sur, à ta place je mettrais direct le ndd pour être tranquille ^^

 

Même après avoir tout remplacé pendant 30 minutes rien n'a changé :fun-msntrucastuce_free_fr-48-acbae:

 

Il y a 2 heures, R4x0r3 a dit :

T'as essayé avec un $_SERVER [HTTP8HOST] à la limite?

 

Please login or register to see this link.

 

Oui et ça n'a rien changé :personnages-52--1720f1:

 

Il y a 1 heure, achrafmaziz a dit :

Essaye:

$_SERVER['SERVER_NAME']

ou:

$_SERVER['REQUEST_URI']

Voir aussi:

Please login or register to see this link.

Please login or register to see this link.

Please login or register to see this link.

Please login or register to see this link.

 

Je vais voir et je te dis quoi :personnages1060-7e969:

 

Merci pour vos réponses je reviens à vous quand il y a du changement.

Share this post


Link to post
Share on other sites
Il y a 8 heures, 乇ᄊノしノѺ a dit :

 

Même après avoir tout remplacé pendant 30 minutes rien n'a changé :fun-msntrucastuce_free_fr-48-acbae:

 

 

Oui et ça n'a rien changé :personnages-52--1720f1:

 

 

Je vais voir et je te dis quoi :personnages1060-7e969:

 

Merci pour vos réponses je reviens à vous quand il y a du changement.

Bon , si "$_SERVER['HTTP_HOST']" ne fonctionne pas c'est que t'as un problème un amont mais quoi hein hein?

Envoie un screen de ton PHP info stp :)!

Share this post


Link to post
Share on other sites
FireWork
Il y a 12 heures, 乇ᄊノしノѺ a dit :

 

Please login or register to see this link.

 

Je m'en remet à vous. :humour-20-13--3fd04d:

 

Please login or register to see this link.

Please login or register to see this link.

Please login or register to see this link.

Share this post


Link to post
Share on other sites
Premium

Holà 

@Scorpio @R4x0r3 @achrafmaziz

 

Après avoir passer toute cette put*n de nuit à essayer toutes les solutions sans succès.

J'ai rager et je me suis dit "Bon NSM je laisse tomber je vais faire autres choses"

J'ai supprimé en premier ma bdd (qui n'avais pas encore été remplie) et mon hébergeur a automatiquement

fait passer ma version PHP de 7.2.7 en 5.6.

Et là, c'est le miracle mon site s'actualise et bim il m'affiche enfin quelques chose.

Mon code était sûrement obsolète pour une version trop élevé de PHP.

J'ai honte d'avoir perdu autant de temps pour ça :falling-86288:mais bon ça fait partie du jeu.

 

Je vous remercie pour toute l'aide apportée. 

Edited by 乇ᄊノしノѺ

Share this post


Link to post
Share on other sites
    Salut 乇ᄊノしノѺ ,
    Ton sujet a été déplacé pour une des deux raisons suivantes :

    - Ta demande a été résolue.

    - Ton sujet se trouvait dans la mauvaise catégorie.

        
      Ceci est un message automatique.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...