Jump to content
  • Please do not post a message for the purpose of insulting, incitement to hatred, sexual remarks and any other which does not respect our terms of use !
Sign in to follow this  
FaYZer

 résolu Problème ftp ou cms ou db ?

Recommended Posts

Saluuut à tous , j'ai acheté depuis peu un hebergement avec le nom de domaine qui va avec sur alls-heberg.fr mais j'ai un probleme : j'ai voulu crée mon retro en r63c du coup pour tester vite fait mon site je mettais des cms au hasard (la plupart de retrophp) et a chaque fois que je fini l'installation du cms , le cms se met mais avec un message d'erreur
Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/vlifeeu/public_html/includes/class/class.mysql.php on line 14 

 

Donc au debut je me disais que sa venanit peut etre de la db de alls-heberg qui est defectueuse jvai en prendre une autre dans un autre site c'est la meme chose , j'ai sois plusieurs message d'erreur en haut de la page avec un cms sans image , soit un cms mit avec un message d'erreur . Je précise que pour l'instant j'ai tester que les cms de RetroPHP vue que c'est les seuls qui sont compatible a la r63c , Donc voila j'aimerais savoir d'ou vient mon problème merccciii

Share this post


Link to post
Share on other sites

Please login or register to see this link.

Mais sache que si tout le cms est en mysql tu devras adapter toutes les requêtes avec un code "à jour"

Donc j’espère pour toi que tu as des bases en PHP ou alors Google deviendra ton meilleur ami

Share this post


Link to post
Share on other sites

Bon je suis partit augmenter ma version PHP , mtn un nouveau message d'erreur apparait c'est celui-ci Warning: PDO::__construct(): php_network_getaddresses: getaddrinfo failed: Name or service not known in /home/vlifeeu/public_html/config/pdo.php on line 4
Erreur : SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: Name or service not known

Share this post


Link to post
Share on other sites
VIP

Salut, il faut que tu mettes à jour tes requêtes MySql vers PDO,

Peut-tu me communiquer ta version actuelle de Php ?

@FaYZer je parle de la version après mise à jour au passage ;) 

Edited by Ubrain

Share this post


Link to post
Share on other sites
Resp modo

Premièrement n'utilise pas les CMS retrophp, ils sont obsolètes et codés avec les pieds

Tu as des CMS bien plus intéressants sur le forum ;) 

Share this post


Link to post
Share on other sites
à l’instant, Ubrain a dit :

Salut, il faut que tu mettes à jour tes requêtes MySql vers PDO,

Peut-tu me communiquer ta version actuelle de Php ?

@FaYZer je parle de la version après mise à jour au passage ;) 

La version php que j'ai mit est celle ci : ea-php72

Share this post


Link to post
Share on other sites
à l’instant, Pancani a dit :

Premièrement n'utilise pas les CMS retrophp, ils sont obsolètes et codés avec les pieds

Tu as des CMS bien plus intéressants sur le forum ;) 

Oui mais sans te mentir je suis des tutos vue que sa fait un baille j'en ai pas crée un et du coup jprend pas de risque a utiliser des cms d'ici pour linstant

Share this post


Link to post
Share on other sites
VIP
à l’instant, FaYZer a dit :

La version php que j'ai mit est celle ci : ea-php72

 

Ok, tu as la dèrnière version de PHP, maintenant assure-toi que dans le fichier "pdo.php", la connexion à la base de données ressemble à ceci 

$bd = new PDO("mysql:host=HOST;dbname=DBNAME", 'UTILISATEUR', 'MDP');

Ce qui est en majuscule doit normalement etre des variables que tu remplis au dessus, ce qui est important ici, c'est la syntaxe (new PDO)

Share this post


Link to post
Share on other sites
à l’instant, Ubrain a dit :

 

Ok, tu as la dèrnière version de PHP, maintenant assure-toi que dans le fichier "pdo.php", la connexion à la base de données ressemble à ceci 

$bd = new PDO("mysql:host=HOST;dbname=DBNAME", 'UTILISATEUR', 'MDP');

Ce qui est en majuscule doit normalement etre des variables que tu remplis au dessus, ce qui est important ici, c'est la syntaxe (new PDO)

Oui elle ressemble a ceci j'ai rempli avec les informations de connexion de ma db

Share this post


Link to post
Share on other sites
VIP

Ah, ce sont les requetes SQL  qui doivent ne pas correspondre, soit tu revois tout le CMS et tu modifies les requettes, soit tu prends un CMS plus évolué... Je n'ai pas d'autres réponses, pour reprendre un CMS et modifier toutes les requetes SQL, cela risque de te prendre un bon bout de temps.

 

Je te recommande d'en chercher un autre, il y en a plein sur Habbo-Dev :p 

Bonne continuation ;) 

Share this post


Link to post
Share on other sites
VIP

Derien, si tu as encore des problèmes n'hésite surtout pas !

Share this post


Link to post
Share on other sites
Premium
Il y a 2 heures, FaYZer a dit :

Bon je suis partit augmenter ma version PHP , mtn un nouveau message d'erreur apparait c'est celui-ci Warning: PDO::__construct(): php_network_getaddresses: getaddrinfo failed: Name or service not known in /home/vlifeeu/public_html/config/pdo.php on line 4
Erreur : SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: Name or service not known

Sa sa veut juste dire que la configuration de la DB est mauvaise, elle ne trouve pas l'hôte distant de la DB, faut juste savoir lire l'anglais un peu '-' 

Share this post


Link to post
Share on other sites
à l’instant, Haci a dit :

Sa sa veut juste dire que la configuration de la DB est mauvaise, elle ne trouve pas l'hôte distant de la DB, faut juste savoir lire l'anglais un peu '-' 

Oups j'ai 4 en anglais mdddr

Share this post


Link to post
Share on other sites
    Salut FaYZer ,
    Ton sujet a été déplacé pour une des deux raisons suivantes :

    - Ta demande a été résolue.

    - Ton sujet se trouvait dans la mauvaise catégorie.

        
      Ceci est un message automatique.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...