Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
  • Please do not post a message for the purpose of insulting, incitement to hatred, sexual remarks and any other which does not respect our terms of use !
Sign in to follow this  
נσα¢кιм

 archive Problème PLUSEMU

Recommended Posts

VIP

Bonjour, 

 

Je rencontre un petit souci que je n'arrive pas à régler moi même.

Je cherche l'erreur depuis hier soir, sur google mais rien , donc peut-être que l'erreur là est arriver a quelqu'un içi.

Quand je voie configuration file, je me dit que le problème viens de la configuration...

Mais non, tous est parfait dans ma config.

 

Sans titre.png 

 

Un petit peu d'aide sera parfait.

 

Bon réveillon , bonne année 2017 ! 

Share this post


Link to post
Share on other sites
Vétéran

Bonjour Joackim, tu dates :p, je pense il manques quelques chose d'important dans ton fichier configuration, ou tu as touché à quelques chose qui fallait pas, essaye de remettre le fichier config de plusemu de base ^^

Share this post


Link to post
Share on other sites
VIP
il y a 2 minutes, Cali a dit :

Bonjour Joackim, tu dates :p, je pense il manques quelques chose d'important dans ton fichier configuration, ou tu as touché à quelques chose qui fallait pas, essaye de remettre le fichier config de plusemu de base ^^

 

Salut Cali, toi de même :o ..

Huum je vais essayer mais je ne pense pas que cela va marcher :x..

Share this post


Link to post
Share on other sites
Vétéran

Ton émulateur fonctionné avant ? Si oui, as-tu debug visualstudio ? donne un peu plus de détails ^^

Share this post


Link to post
Share on other sites
VIP
il y a 2 minutes, Joackim a dit :

 

Salut Cali, toi de même :o ..

Huum je vais essayer mais je ne pense pas que cela va marcher :x..

Alors il manque bien quelque choses dans mon fichier config, mais je ne sais même pas quoi rajouter lol..

 

Share this post


Link to post
Share on other sites
Vétéran
à l’instant, Joackim a dit :

Alors il manque bien quelque choses dans mon fichier config, mais je ne sais même pas quoi rajouter lol..

 

 

Montre nous le fichier

Share this post


Link to post
Share on other sites
Vétéran

Tiens essaye cela :

 

# // MySQL Configuration
db.hostname=
db.port=3306
db.username=
db.password=
db.name=
# // MySQL pooling setup (controls amount of connections)
db.pool.minsize=10
db.pool.maxsize=250
## Game TCP/IP Configuration
game.tcp.bindip=
game.tcp.port=
game.tcp.conlimit=100000
game.tcp.conperip=200
game.tcp.enablenagles=true
## MUS TCP/IP Configuration
mus.tcp.bindip=
mus.tcp.port=
mus.tcp.allowedaddr=
## Client configuration
client.ping.enabled=1
client.ping.interval=20000
client.maxrequests=300

 

Share this post


Link to post
Share on other sites
VIP
il y a 3 minutes, xToz a dit :

 

Montre nous le fichier

Sans titre.png

Share this post


Link to post
Share on other sites
VIP

Share this post


Link to post
Share on other sites
Vétéran

Essaye de mettre le port " 30000 " pour voir, et dans le MUS supprime " localhost;" mais simplement l'ip de ton VPS,  tu as pas oublié de modifier le " ; " de l'horloge ? 

Share this post


Link to post
Share on other sites
Vétéran
il y a 8 minutes, Cali a dit :

Essaye de mettre le port " 30000 " pour voir, et dans le MUS supprime " localhost;" mais simplement l'ip de ton VPS,  tu as pas oublié de modifier le " ; " de l'horloge ? 

Ne JAMAIS ouvrir le MUS à tout le monde, vous êtes idiots ou quoi ?

Le MUS c'est une APi json je crois, si tu broadcast le MUS a tout le monde je peux me give autant de crédits/diamants et me mettre rank 9...

Share this post


Link to post
Share on other sites
Vétéran

Je ne sais pas, d'ou tu sort cela, pendant des années pleins de développeurs compétents, le supprimai il y a jamais rien eu .. Je te conseille d'en apprendre d'avantages sur les émulateurs.

Share this post


Link to post
Share on other sites
Vétéran
il y a 2 minutes, Cali a dit :

Je ne sais pas, d'ou tu sort cela, pendant des années pleins de développeurs compétents, le supprimai il y a jamais rien eu .. Je te conseille d'en apprendre d'avantages sur les émulateurs.

 

Va lire le code de PlusEMU.

 

Le MUS est une API externe, elle est la pour la compatibilité avec de VRAIS cms qui utilisent cette API (Habboon l'utilisaient)

C'est pas une faille, c'est juste qu'il ne faut pas l'ouvrir et la restreindre via le pare feu ou laisser localhost.

 

Je te conseille d'en apprendre d'avantage sur l'informatique au lieu de parler sans connaissance de cause :)

Share this post


Link to post
Share on other sites
Vétéran

Si tu me crois pas, met le MUS sur l'ip de ton vps et je me met rank 9.

Après tu verra tu la laissera sur localhost

Share this post


Link to post
Share on other sites
Vétéran

Bon chut un peu, vaux mieux, Allez bonne journée.

Share this post


Link to post
Share on other sites
Vétéran
il y a 1 minute, Cali a dit :

Bon chut un peu, vaux mieux, Allez bonne journée.

 

T'as 15 ans ou quoi ?

Tu critique alors que je dis la vérité...

Grandis un peu, t'as besoin de maturité avant de critiquer ceux qui ont de l'expérience dans l'industrie :)

Share this post


Link to post
Share on other sites
Vétéran

Mdr, tu me fais bien rire " grandis un peu " qui dis " débrouille toi " sur un forum d'aides ?, je critiques pas, j'affirme que tu dis n importe quoi. 

Sur ceux, fin du débat, le sujet n'ai pas fais pour s'embrouillé et je ne parle pas avec quelqu'un d'aussi prétentieux. 

Share this post


Link to post
Share on other sites
Vétéran

 

il y a 47 minutes, Joackim a dit :

Bonjour, 

 

Je rencontre un petit souci que je n'arrive pas à régler moi même.

Je cherche l'erreur depuis hier soir, sur google mais rien , donc peut-être que l'erreur là est arriver a quelqu'un içi.

Quand je voie configuration file, je me dit que le problème viens de la configuration...

Mais non, tous est parfait dans ma config.

 

Please login or register to see this link.

 

 

Un petit peu d'aide sera parfait.

 

Bon réveillon , bonne année 2017 ! 

Tu as remplacer la , par un . dans le format de l'heure ?

Share this post


Link to post
Share on other sites
Vétéran
il y a 11 minutes, Aquazus a dit :

Si tu me crois pas, met le MUS sur l'ip de ton vps et je me met rank 9.

Après tu verra tu la laissera sur localhost

Suffit de le restreindre a l'ip sur lequel il veut l'utiliser ^^

Share this post


Link to post
Share on other sites
Vétéran

Dodone toi même qui est un développeur compétent, tu as pas laisser localhost ^^

 

1483187961.png

Share this post


Link to post
Share on other sites
Vétéran
il y a 11 minutes, DodoneOfficiel a dit :

Suffit de le restreindre a l'ip sur lequel il veut l'utiliser ^^

 

D'ou l'intéret de le configurer correctement...

il y a 9 minutes, Cali a dit :

Dodone toi même qui est un développeur compétent, tu as pas laisser localhost ^^

 

1483187961.png

 

Sur mus.tcp.bindip tu met l'IP de ton vps, normal

et sur mus.tcp.allowedaddr tu met la liste des IP autorisés à utiliser l'API

exemple:  127.0.0.1;62.135.35.132

Tu sépare par des ;

Mais évite de mettre l'IP du VPS et/ou 0.0.0.0

Share this post


Link to post
Share on other sites
Vétéran

Si tu met pas l'ip de ton VPS, le client fonctionne pas :/

Share this post


Link to post
Share on other sites
Vétéran

Personnellement j'ai refait mon système de socket a fin de mieux le protéger.

Please login or register to see this link.


Please login or register to see this link.

 

Share this post


Link to post
Share on other sites
VIP

Alors, je laisse localhost ou je l'enlève?

Mais mon souçi,viens de ou?

Share this post


Link to post
Share on other sites
VIP
il y a 48 minutes, DodoneOfficiel a dit :

 

Tu as remplacer la , par un . dans le format de l'heure ?

Oui cst la première chose que j'ai regarder mdrr

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...