Jump to content

Cloudfordream -  NabboHotel -  CloudCMS

Bienvenue sur Habbo-Dev !

  • Veuillez ne pas poster de message pour but d'insulter, incitation à la haine, propos sexuels et tout autre qui ne respecte pas nos conditions d'utilisation !
Sign in to follow this  
Akrino

 résolu Problème page cms

Recommended Posts

Bonjour à tous;

 

Je viens à vous pour vous faire part d'un problème que j'ai trouvé.

J'ai compris le soucis mais je ne saurais pas le régler tout seul.

 

Explications :

Sur mon CMS, j'ai une page "Signaler un problème" (Please login or register to see this link. ), ou les joueurs peuvent envoyer des demandes d'aides.

Une fois qu'ils ont cliqués sur "Envoyer ma demande d'aide", je reçois la demande d'aide sur le panel administration (Please login or register to see this link. ) ainsi que dans ma base de donnée (Please login or register to see this link. ) dans la table "cms_report".

 

Le problème étant que, lorsque une demande d'aide est envoyé, je ne peux en recevoir qu'une sur la panel d'administration ainsi que dans la table de la base de donnée.

En gros quand une demande d'aide est faites : l'ID de cette demande dans la table "cms_report" est de 1 et cela pour toutes les demandes d'aides qui arriveront.

Ce qui veut dire que toutes les demandes d'aides envoyées auront l'ID : 1 dans la DB donc ça remplace l'ancienne demande non résolue par la nouvelle qui arrive!

C'est embêtant!

 

J'aimerai donc si c'est possible de l'aide avec un code à changer ou quoi pour avoir plusieurs ID et garder toutes les demandes d'aides dans la bdd et sur le panel!

 

Voici les screens des fichiers.php nécessaires je pense:

 

panel d'administration avec toutes les demandes d'aides:

Please login or register to see this link.

page pour signaler un problème (regarder ou j'ai entouré je pense que c là pas sur):

Please login or register to see this link.

 

Merci de votre aide!

 

Cordialement,

 

Share this post


Link to post
Share on other sites

Suffis de mettre l'ID en AUTO_INCREMENT

 

Petit conseille pour un SELECT sans valeur assigné pas besoin d'une requête préparer.

Edited by Akushi

Share this post


Link to post
Share on other sites

Salut,

 

Les demandes d'aide complètes sont rares mddr Tu as juste à aller dans l'onglet strucyure de ta table où se trouvent les tickets et tu mets la colonne "id" en AUTO_INCREMENT

 

Ça devrait le faire

 

- Synxgz

Share this post


Link to post
Share on other sites
il y a 29 minutes, Akushi a dit :

Suffis de mettre l'ID en AUTO_INCREMENT

 

Petit conseille pour un SELECT sans valeur assigné pas besoin d'une requête préparer.

 

il y a 29 minutes, Synxgz a dit :

Salut,

 

Les demandes d'aide complètes sont rares mddr Tu as juste à aller dans l'onglet strucyure de ta table où se trouvent les tickets et tu mets la colonne "id" en AUTO_INCREMENT

 

Ça devrait le faire

 

- Synxgz

Oui j'aime bien qu'on comprenne mon problème mddr.

D'accord, alors j'ai juste à aller dans la table cms_report, Structure en haut et je met le truc ID j'vous redis ça merci ;) !

Share this post


Link to post
Share on other sites

L'ID est déjà en AUTO_INCREMENT, et maintenant quand je clique sur Envoyer la demande d'aide, ça le met même plus dans la db ni dans le panel d'administration

Share this post


Link to post
Share on other sites

PROBLÈME RÉGLÉ !

 

Il suffisait de rajouter ".$news["id"]." dans la valeur pour l'ID ici :

Citation

Please login or register to see this link.

Car sinon ça mettait aucun ID

 

Merci quand même ;) !

Share this post


Link to post
Share on other sites
    Salut Akrino ,
    Ton sujet a été déplacé pour une des deux raisons suivantes :

    - Ta demande a été résolue.

    - Ton sujet se trouvait dans la mauvaise catégorie.

        
      Ceci est un message automatique.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

×
×
  • Create New...